Automatically convert deprecated APIs for Kubernetes 1.16

When Kubernetes 1.16 was released, several beta APIs were deprecated in favor of their stable counterparts. This means that your deployments will fail, if you’re still using the old APIs (as hundreds of public helm charts are!)


This is a companion discussion topic for the original entry at https://friends.funkypenguin.co.nz/note/transmogrify-deprecated-kubernetes-apis/